0
Errore Parametri insufficienti. Previsto 6
Problem reported by Demetria Fundament - May 5, 2008 at 2:02 AM
Resolved
nei prossimi mesi apriro' un negozio prevalentemente di alimentari, in quest'ottica, avevo intenzione di valutare la Vs. SW ALCA magazino e relativi accessori, ho quindi scaricato la demo, ma purtroppo mi sono scontrato con diversi errori tipo: Procedure : ALCASDK.Database.get_Recordset Error.Source : Microsoft OLE DB Provider for ODBC Drivers Error.Number : -2147217904 Error.Description : [Microsoft][Driver ODBC Microsoft Access] Parametri insufficienti. Previsto 6. AdditionalInformation : SELECT Banco.Codice, Descrizione, Banco.Quantità, PrezzofinalevenditaconIVA, Sconto, Banco.IVA, Seriale_codice, Causale, Banco.Data, format(Banco.Data,'dd/mm/yyyy') as DataSemplice, Banco.[Note], Banco.Taglia, Banco.Colore, Bloccat> o, Tipo_riga, ID, RagioneSociale, PartitaIVA, (ListinoIVATO*Banco.Quantità) AS Costo, (PrezzofinalevenditaconIVA-(ListinoIVATO*Banco.Quantità)) AS Ricavo, TipoPagamento , ListinoIVATO , FidelityAssegnati , Reso , ResoData , format(Banco.ResoData,'dd/mm/yy> yy') as ResoDataSemplice, ProvenienteDaDocumento , ProvenienteIDFattura , MetaArticolo FROM Banco WHERE FORMAT(BANCO.DATA,'DD/MM/YYYY') = #06/30/2006# ORDER BY Data DESC , data_creazione DESC ...ho visto che nel forum si indicava quale causa un malfunzionamento di windows installer... ho provato su piu' PC, ma sempre con lo stesso risultato. Se pur questo non compromette il funzionamento del programma, è evidente che non si possa lavorare con questo tipo di problematiche, vi prego quindi di indicarmi una possibile soluzione in modo da poter testare il SW e prendere una decisione in merito. Vi ringrazio per una pronta risposta

10 Replies

Reply to Thread
0
Enrico Ferraro Replied
May 5, 2008 at 2:02 AM
d1) Quale versione sta usando? d2) Ha scaricato ed installato versioni precedenti? d3) Quando e come esce il primo errore? www.info2000.biz
0
Demetria Fundament Replied
May 5, 2008 at 2:02 AM
1) Ho scaricato dal Vs. sito la versione demo 9.7.4 2) Il giorno precedente, avevo scaricato (da un altro sito), grazie al quale comunque vi ho conosciuto, una versione precedente, se non erro era la 9.6.4... non ne sono certo, in ogni caso dava i medesimi errori e dopo la disinstallazione ho proceduto ad una pulizia del registro di windows (ho comunque provato anche su computer dove la SW non è mai stata installata (tutti con windows XP SP2) 3)Subito dopo la mascherina che avvisa "la versione scadrà tra 15gg", esce l'errore "ALCASDK.Misc.set_serial" di seguito dando "ok" esce l'errore "ALCASDK.Database.get_Recordset", ancora di seguito l'errore "ALCASDK.Lavorativi.exit" ancora di seguito "ALCASDK.Lavorativi.set_GiornoLavorativo" e finalmente si apre la schermata iniziale. All'apertura di magazino, globale e schede clienti, nessun errore, mentre se torno al menu ripete gli errori precedenti. All'apertura di Banco ripete due volte l'errore "ALCASDK.Database.get_Recordset", tutti gli altri ripetono gli errori di cui sopra al ritorno nel menu. In uscita dal programma esce l'errore "ALCASDK.Giacenze.Update" di seguito "ALCASDK.Giacenze.Delete". Devo dire che con tutti questi errori non ho provato molto il programma, una delle poche cose che ho fatto è stato il tentativo di inserire un prodotto nel magazzino e qui c'è un grosso errore di calcolo, non con tutti i prezzi, ma inserendo per esempio un prezzo di 23 senza iva e un ricarico del 20% esce al pubblico un prezzo di 276 !? il che mi lascia alquanto perplesso.... Resto in attesa di una vostra cortese risposta
0
Enrico Ferraro Replied
May 5, 2008 at 2:02 AM
Buongiorno, non risultano ad oggi difetti neanche così gravi si tratta quindi di un fatto locale, posso solo consigliare di rimuovere alca, quindi cancellare manualmente la cartelle di installazione in \programmi\info2000\alca e quindi procedere ad una nuova installazione. www.info2000.biz
0
Demetria Fundament Replied
May 5, 2008 at 2:02 AM
Ho disinstallato, cancellato, ripulito e re-installato... sempre gli stessi errori!! Ho provato il programma su 4 PC differenti, con configurazioni completamente differenti e di marche diverse, solo il S.O. era identico. Quindi a meno che il problema non sia da ricondurre a Windows XP SP2, ho qualche difficolta a ritenere il problema "locale". In ogni caso, se non siete in grado di darmi altre soluzioni, non mi resta che valutare altri prodotti. Vi ringrazio comunque per l'attenzione.
0
Enrico Ferraro Replied
May 5, 2008 at 2:02 AM
E' stata eseguita una installazione su una macchina XP pulita e non è stato rilevato alcun difetto. Se può, ci invii il file "base dati alca.mdb" in modo che possiamo dare uno sguardo. www.info2000.biz
0
Demetria Fundament Replied
May 5, 2008 at 2:02 AM
Ho inviato il file Base Dati AlCa.mdb a forum@info2000.biz
0
Enrico Ferraro Replied
May 5, 2008 at 2:02 AM
Per cortesia l'indirizzo è basedati@info2000.biz o www.info2000.biz
0
Enrico Ferraro Replied
May 5, 2008 at 2:02 AM
Spiacenti ma non sono stati riscontrati, a questo punto vedo due possibilità: 1) verifichi nel pannello di controllo che sia presente la connessione ALCA e che punti al file base dati alca.mbd 2) qualora non funzioni ancora, provi a scaricare la beta disponibile da oggi e scaricabile da questo forum www.info2000.biz
0
Demetria Fundament Replied
May 5, 2008 at 2:02 AM
Anche la beta mi da gli stessi errori. Nel pannello di controllo non è presente nessuna connessione ALca!!!!
0
Enrico Ferraro Replied
May 5, 2008 at 2:02 AM
Strano che non sia stata creata comunque, la può creare manualmente abbastanza facilmente: 1) System DSN 2) Aggiungi 3) Selezioni Access (*.mdb) 4) Nel nome data source scriva AlCa 5) come database punti al file base dati alca.mdb www.info2000.biz

Reply to Thread