0
Errore registrazione fattura: Il campo "Fatture Dati.Posizione" non può contenere una stringa di lunghezza zero.
Problem reported by stebo - June 10, 2008 at 9:48 AM
Resolved
Gentile Assistenza, vi riporto qui di seguito i messaggi di errore che ho da qualche gg.

Questo messaggio mi è apparso oggi quando stavo registrando una fattura:

----------------------------------------------------------------
Procedure: ALCASDK.ALCASDK.Documenti.set_Documento
Error.Source: Microsoft JET Database Engine
Error.Number: -2147467259
Error.Description: Il campo "Fatture Dati.Posizione" non può contenere una stringa di lunghezza zero.
DB Used: Access
AdditionalInformation: 778::UPDATE [Fatture Dati] SET Numero = '12', IDcontatto = '11', Data = #06/09/2008#, DataSpedizione = #06/09/2008#,Corriere = '', Scadenza = #06/10/2008#, Stato = '', Costospedizione = '0',Proprietà = 'Ingresso', PartitaIVA = 'IT02000460150', Pagamento = '', Colli = '0',Ora = #07:41:02#, Porto = '', Riferimento = '', Indirizzo = 'VIA QUINTINO SELLA, 19',Città = 'CORSICO', Provincia = 'MI', CAP = '20094',Preventivo = False, Contratto = False, Posizione = '', TotaleFattura = '0',DestinazioneAggiuntiva_RagioneSociale = '', DestinazioneAggiuntiva_Indirizzo = '', DestinazioneAggiuntiva_Cittá = '',DestinazioneAggiuntiva_Provincia = '', DestinazioneAggiuntiva_CAP = '', Causale = '', TipoDocumento = 'Fattura',Intestazione1 = '', Intestazione2 = '', Intestazione3 = '', Intestazione4 = '',Intestazione5 = '', Intestazione6 = '', Intestazione7 = '', Intestazione8 = '',Intestazione9 = '', Intestazione10 = '', Note1 = '', Note2 = '',Note3 = '', DirezioneContabile = '1' WHERE IDFattura=117
ALCA.version: 9.7.18
ALCA.SDK v.: 9.7.283
ALCA.Instance: 00-02-5B-01-41-4E
----------------------------------------------------------------
================================================================================
Errors stack:
(1) Microsoft JET Database Engine - Il campo "Fatture Dati.Posizione" non può contenere una stringa di lunghezza zero. [-2147467259]
(2) Microsoft JET Database Engine - Il campo "Fatture Dati.Posizione" non può contenere una stringa di lunghezza zero. [-2147467259]
(3) Microsoft JET Database Engine - Il campo "Fatture Dati.Posizione" non può contenere una stringa di lunghezza zero. [-2147467259]
(4) Microsoft JET Database Engine - Il campo "Fatture Dati.Posizione" non può contenere una stringa di lunghezza zero. [-2147467259]
(5) ALCASDK - Variabile oggetto o variabile del blocco With non impostata [91]
(6) ALCASDK - Il componente ActiveX non può creare l'oggetto [429]
(7) ALCASDK - Il componente ActiveX non può creare l'oggetto [429]
(8) ALCASDK - Il componente ActiveX non può creare l'oggetto [429]
(9) Microsoft JET Database Engine - La tabella 'VistaSugliArticoliInUscita' non esiste. [-2147217865]
================================================================================

Non mi permette di salvare una fattura in entrata.

Altro errore è quando faccio partire il programma:

----------------------------------------------------------------
Procedure: UpgradeDataBase.bas.UpgradeDataBase
Error.Source: ALCASDK
Error.Number: 429
Error.Description: Il componente ActiveX non può creare l'oggetto
DB Used: Access
ALCA.version:
ALCA.SDK v.: 9.7.283
ALCA.Instance: 00-02-5B-01-41-4E
----------------------------------------------------------------
================================================================================
Errors stack:
(1) ALCASDK - Il componente ActiveX non può creare l'oggetto [429]
(2) Microsoft JET Database Engine - La tabella 'VistaSugliArticoliInUscita' non esiste. [-2147217865]
================================================================================

clicco varie volte su si per collegarmi con il forum e lo devo fare per 3/4 volte.

L'ultimo messaggio di errore che appare è questo:

----------------------------------------------------------------
Procedure: UpgradeDataBase.bas.UpgradeDataBase
Error.Source: ALCASDK
Error.Number: 91
Error.Description: Variabile oggetto o variabile del blocco With non impostata
DB Used: Access
ALCA.version:
ALCA.SDK v.: 9.7.283
ALCA.Instance: 00-02-5B-01-41-4E
----------------------------------------------------------------
================================================================================
Errors stack:
(1) ALCASDK - Variabile oggetto o variabile del blocco With non impostata [91]
(2) ALCASDK - Il componente ActiveX non può creare l'oggetto [429]
(3) ALCASDK - Il componente ActiveX non può creare l'oggetto [429]
(4) ALCASDK - Il componente ActiveX non può creare l'oggetto [429]
(5) Microsoft JET Database Engine - La tabella 'VistaSugliArticoliInUscita' non esiste. [-2147217865]
================================================================================
Il programma comunque parte ugualmente.

Che cosa posso aver fatto?

E' possibile risolvere il problema?

Ringrazio - Stefano


 

7 Replies

Reply to Thread
0
Enrico Ferraro Replied
June 10, 2008 at 10:23 AM
Salve,

usava una versione precedente di ALCA ed ha installato recentemente la 9.8?

Invii la sua base dati per un controllo.

0
stebo Replied
June 10, 2008 at 11:22 AM
Avevo al 9.7.18 e ho provato ad installare l'ultima versione ma non funzionava.

Siccome del programma ho bisogno, ho disinstallato e reinstallato la vecchia.

Lei mi dice di inviare il file base dati?

Sistemerete tutto da li?

Un'altra domanda, una volta che mi rimandate il file, tengo la versione vecchia o la aggiorno con la ultima?

Ringrazio e saluto.

0
stebo Replied
June 10, 2008 at 2:41 PM
IO ATTUALMENTE HO LA 9.7.18 E HO GLI ERRORI CHE HO SCRITTO ALL'INIZIO DEL POST.

COME POSSO FARE PERCHè SI ELIMININO? MI SCUSI MA NON HO CAPITO COME FARE.

STEFANO

0
stebo Replied
June 10, 2008 at 2:57 PM
OK, MI INTERESSA PASSARE ALLA VERIONE ULTIMA.

CI SONO DEI COSTI?

DA COME HO LETTO BASTA CHE VI INVIO IL FILE, GIUSTO?

STEFANO

0
stebo Replied
June 11, 2008 at 11:29 PM
Gentile sign. Ferraro, prima di procedere con l'invio del file base dati, avrei da fare questa puntualizzazione:

secondo me  gli errori risontrati, non dipendono dal file base dati, perchè se inserito lo stesso file in un'altro pc e fatto partire alca, il programma non da segni di errore.

Può essere che ci sia qualche file di registro, che rompa le scatole?

Anche a operazione inversa, mettendo il file base dati che avevo salvato la settimana scorsa, mi da sempre errore quando lo apro.

Stefano

0
stebo Replied
June 12, 2008 at 10:34 AM
ok, ma una ultima cosa poi non disturbo più:

non sapete installando alca che file vengono modificati?

Sicuramente è stato modificato qualche file di registro penso.

Stefano

0
stebo Replied
June 12, 2008 at 11:33 AM
ok tenterò, mi può dire dove trovo gli mdac, che non riesco a trovarli nel sito con il tasto cerca?

Stefano

Reply to Thread