0
carico fatture
Problem reported by ORAZIO - April 8, 2011 at 5:45 PM
Resolved
----------------------------------------------------------------
Procedure: ALCA.SDK.Net.COM.Anagrafica.Anagrafica.Get_Contatti
Error.Source: INFO2000.Business.ALCA.SDK.Net
Error.Number: 0
Error.Description: Variabile oggetto o variabile del blocco With non impostata.
   in INFO2000.ALCA.SDK.Net.Anagrafica.Get_Contatti(Contatti TipoContatto, Collection& COM_Results, String TipoContattoNonStandard, Boolean ElencoCompleto, String RagioneSociale, String PartitaIVA)
   in INFO2000.ALCA.SDK.Net.COM.Anagrafica.get_Contatti(Contatti TipoContatto, String TipoContattoNonStandard, Boolean ElencoCompleto, String RagioneSociale, String PartitaIVA)
DB Used: SqlServer
ConnectionString: Provider=SQLOLEDB.1;Data Source=FAGGIN01\SQLEXPRESS;Initial Catalog=ALCA;User ID=AlCa;pwd=qUc4LpsQouKXmCm; Pooling=True; Max Pool Size=100; Min Pool Size=1;;
LastSql: select * from Anagrafica where  IDContatto IN ( SELECT distinct (IDContatto) FROM Anagrafica WHERE [TipoContatto] = 'Fornitore' AND 1=1 AND [RagioneSociale] LIKE '%SC%' ) order by RagioneSociale
ALCA.version: 9.8.18
ALCA.Beta.version: 16
ALCA.SDK v.: 9.8.580
ALCA.Instance: 485B39ABEE7D
----------------------------------------------------------------
================================================================================
Errors stack:
(1) INFO2000.Business.ALCA.SDK.Net - Variabile oggetto o variabile del blocco With non impostata.
   in INFO2000.ALCA.SDK.Net.Anagrafica.Get_Contatti(Contatti TipoContatto, Collection& COM_Results, String TipoContattoNonStandard, Boolean ElencoCompleto, String RagioneSociale, String PartitaIVA)
   in INFO2000.ALCA.SDK.Net.COM.Anagrafica.get_Contatti(Contatti TipoContatto, String TipoContattoNonStandard, Boolean ElencoCompleto, String RagioneSociale, String PartitaIVA) [0]
================================================================================
Buongiorno,

succede una cosa strana, sto caricando una fattura e nel campo ricerche non mi trova un fornitore già presente in anagrafica e sembra non veda alcun fornitore, poi girandoci un pò riesco ad inserire il fornitore, ma non mi salva la fattura da caricare.

Grazie

Saluti

Orazio

3 Replies

Reply to Thread
0
Enrico Ferraro Replied
April 9, 2011 at 1:10 PM
Buongiorno,

in effetti non tira su la lista dei fornitori :hehe:

Putroppo non sono riuscito a trovare il punto che genera l'errore, mi servirebbe che avviasse ALCA in modalità di debug, arrivi all'errore, quindi disabiliti la modalità di debug, esca da ALCA ed alleghi al forum il file .sil generato.

Eventualmente guardi nelle faq di alca: "Mi avete chiesto di spedirvi il file di .log (debug): ma come si fa'?"

Grazie
0
ORAZIO Replied
April 11, 2011 at 8:43 PM
Buongiorno,

ho provato come suggerito in modalità debug mi ha caricato la fattura senza problemi, anche in modalità normale ha funzionato normalmente. Bohh. Come da topic precedente ogni tanto succedono cose strane. Tutto bene quel che finisce bene.

Saluti Orazio

0
Ada Stallone Replied
April 27, 2011 at 8:45 PM
.

Reply to Thread